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  Overview

Getting started

Basic information for administrators

Cross references to detailed information in other documents and to the 
online help found in the Switchvox Admin Tools Web Suite
The combination of the Switchvox PBX and Digium IP Phones provides a complete, 
unified communications solution for small and mid-sized businesses. This unified 
communications system integrates all office communications, including phone, fax, 
chat, and web mashups. This guide gives administrators basic information for quick 
setup of both Switchvox and the Digium Phones. Cross references point to detailed 
information in other documents.

1—Switchvox Installation & 
Network Configuration 
(page 5)

Installation of the Switchvox server 
appliance and configuration of the 
server and phone networks

2—System Basics (page 10) Registration, updates, managing of 
backups

3—Phones and Calling (page 14) Digium Phones, call routing, and 
contacts

4—Customer Service (page 22) Time frames, call queue extensions, 
IVRs, conference calls, voicemail 
administration
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1 Switchvox Installation & 
Networking

Switchvox Server Setup

Switchvox Server Network Information

Digium Phone Network Information

Network Management
Getting your Switchvox system up and running requires first setting up your Switch-
vox server appliance and connecting it to a power supply and a network. After the 
server appliance is operational, you need to configure its network. This chapter gives 
you step-by-step instructions for doing this as well as information about Digium 
Phone networks and network management.

Switchvox Server Setup
If your server appliance needs any hardware expansion cards, install them according 
to instructions in the appropriate appliance quick start guide (see the Digium support 
web page). 

Connect the appliance to all the necessary external connections: network interface, all 
incoming lines from your telephone providers, any other physical connections from 
external devices.

Turn on the appliance.

The Switchvox software is already installed. 

Put the included Switchvox installation DVD in a safe place in case you need to rein-
stall the system at a later time. 

Switchvox Server Network Information
After the main display LCD displays the message, Press any key, it is ready to be 
configured. 

• Press any key to start the process.

• Use the Up and Down directional keys to select Configure Network, then click 
the green checkmark.
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Switchvox Server Network Information
• Use the Up and Down directional keys to select Set DHCP/Static, then click the 
green checkmark.

• Use the Left and Right directional keys to select either DHCP or Static, then click 
the green checkmark.

NOTE: We recommend setting a static IP address because it is important that the 
Switchvox server IP address remains the same after it has been configured and 
users are connecting to it. 

NOTE: To find an IP address that is not in use on your network and will not be 
used for another client by the DHCP server or used by some other devices, go to 
the following web site and look at the information for your particular router:
http://www.portforward.com/routers.htm.

Setting a Static IP 
Address

To use the static setting, enter the following IP addressing information:

• IP Address provided by your network administrator.

• Netmask. By default, the netmask is 255.255.255.0. If your netmask address is 
different, change it to the correct value.

• Gateway (or router). The address for your gateway is usually the IP address of 
your router. A common gateway IP address is 192.168.0.1.

• DNS Server. This address is for either a server inside your network or a server 
your Internet Service Provider (ISP) runs for you. If your ISP runs your DNS, the 
ISP network administrator can provide this address.

After you are done entering the IP address information, use the Up and Down direc-
tional keys to select Save Net Settings. 

This completes the configuration using a Static IP Address.

Setting a DHCP IP 
Address

If your router can assign IP addresses using DHCP (Dynamic Host Configuration Pro-
tocol), then you can use this method to assign the Switchvox IP address. However, we 
recommend you configure your DHCP server to reserve an IP address specifically for 
Switchvox because each time Switchvox reboots, it retrieves the IP address. 

• On your router, enter the MAC address of the active network card in the 
Switchvox server. This MAC address is displayed on the Switchvox server screen 
as a series of six number or letter combinations separated by colons (e.g., 
00:11:11:AF:2A:EA). 

NOTE: Because DHCP works differently on different routers, contact your 
router’s manufacturer or look in your router’s user manual for instructions.

• After you have set up your router, select DHCP from the appliance menu.

• Then use the Up and Down directional keys to select Save Net Settings. 

This completes the configuration using a DHCP IP address.

Switchvox Admin Tool 
Suite URL

Use the Up and Down directional keys to select View System Info.This displays the 
URL for the web-based Switchvox Admin Tool Suite. 

IMPORTANT: The Switchvox Admin Tool Suite is the primary means of 
managing the Switchvox system. You can access the tool suite from any 
computer on your network via a web browser. 
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Digium Phone Network Information
Digium Phone Network Information

Switchvox’s Phone Networks determine how a Digium Phone should behave, depend-
ing on the IP address and netmask of the phone as it sits on the network.

IMPORTANT: For a remote phone, that is not on the same network as Switchvox, 
make sure that you have Access Control Rules in place, and that your router is 
forwarding the appropriate ports to Switchvox. See “Network Management” ( 
page 7).

Usually the two default phone networks Internal and All Networks encompass most
situations:

• Phones located on the same network as Switchvox (Internal)

• Phones located on any other network (All Networks)

So, it is unlikely you will need to modify the default phone networks, or to create 
additional phone networks. These default entries are automatically updated so that Host 
Address is the same as Switchvox's internal and external IP addresses (those are 
managed in IP Configuration).

The Select Network tool on your phone lists all the phone networks and lets you select 
which one to use. See “Phone Tools” ( page 17) for more on this.

Creating Phone 
Networks

To create or modify a phone network, go to Server > Networking > Phone Networks. 
See the Switchvox Admin Reference Manual, “Phone Networks” ( page 122). 

Troubleshooting 
Network Issues

You can use the tools on the phone to help troubleshoot network issues. See “Phone 
Tools” ( page 17).

Finding 
Switchvox

If your Phone Networks are not set up correctly in Switchvox, or the phone was never 
plugged into a network local to Switchvox, the phone may not be able to find 
Switchvox. In that situation, you can manually direct the phone to Switchvox by 
pressing the phone’s Settings softkey and doing the following:

1. Select Digium Configuration Server.

2. Enter the IP address or hostname of your Switchvox, and a port number (most likely 
5060).

After the phone finds Switchvox and gets its configuration, you can make calls. 

Network Management
You can use basic routers such as Linksys, Netgear, or D-Link home models. If you are 
considering a more complex network, check your business requirements to be sure you 
need it. Most issues with VoIP systems can be traced to networks, not to the phones or 
Switchvox. 
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Network Management
Switchvox and Phone 
Placement

Place Switchvox on the same LAN segment as the phones, and Switchvox, phones, 
and other networked computers on the same subnet or private network.

Most customers keep Switchvox on a private IP; however, it can be put on a public IP 
in a DMZ. In either case, place a firewall in front of your Switchvox system, even if it 
is on a public IP address. A firewall lets you control which IPs have access to your 
Switchvox services.

You can use an alternate network or VLAN to segment the Switchvox system and 
phones from the LAN.

Quality of Service 
(QoS)

If you plan to use a VoIP service provider, it is a good idea to use QoS to prioritize 
your traffic. QoS assures voice quality even if your internet connection is saturated 
with other traffic by giving higher priority to the traffic going in and out of Switch-
vox. Consult your router documentation for how to set up QoS rules to prioritize VoIP 
traffic. This can be done by giving priority to your Switchvox MAC address or IP 
address.

If you are using QoS in your network equipment, you can set up Switchvox to send 
the correct ToS or DSCP field in all VoIP packets. This field can be used by firewalls 
and switches to distinguish specific types of traffic to apply QoS rules, such as favor-
ing all voice traffic for better quality. 

To do this, go to your Switchvox Web Admin website and select Setup > Networking 
> IP Configuration. On the IP Configuration page, click Advanced Options, then 
select the Audio and Video options you want. The default settings should work fine; 
however, if you know what you are doing you might want to change these.

In most cases, you do not need a QoS switch. Unless you consume massive amounts 
of bandwidth transferring large files among computers in your local network, you do 
not need a managed switch. Remember that QoS on the switch is not a replacement 
for QoS on your router.

Access Control Switchvox's Access Control tool (Setup > Networking > Access Control) lets you 
set network access to Switchvox services based on IP address and netmask. The 
default action is to deny access. So if you do not allow a service for a network, then 
the network is denied access to that service. 

If you need to use the Switchboard, be sure to enable access to the XMPP services.

Port 
Forwarding 
for Remote 
Access

If you plan to use phones or to access Switchvox from remote locations, you must for-
ward certain ports back to Switchvox. A good resource for documentation on how to 
forward ports on most routers is: www.portforward.com.

To enable port forwarding, open 

• Setup > Networking > IP Configuration
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Network Management
The following table lists the TCP/UDP port assignments and how Switchvox uses 
them.

TCP/UDP Port(s) Switchvox Use

UDP 5060 SIP signaling port for phones outside your 
network

UDP 5062 SIP signaling port for phones for configura-
tion communications

UDP 10000-20000 RTP audio ports for phones outside your 
network

SIP UDP 4000-4999 UDPTL ports for T.38 faxing over SIP

IAX UDP 4569 IAX Signalling Port needed for communi-
cating with IAX provider

TCP 80 HTTP port for remote web voicemail 
access

TCP 443 HTTPS port for remote web admin access

TCP 5222 & 843 SMB Systems Only - ports for using the 
Switchboard remotely

TCP 5269 SMB Systems Only - port for remote 
XMPP (Jabber/chat) access (Extensible 
Messaging and Presence Protocol)

UDP 1194 Must be open to outgoing traffic
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2 System Basics

Registering

Updating

Backups
After the hardware and network setup is complete, you need to register your Switch-
vox system and know how to update the Switchvox system software and manage 
backups. This chapter describes these basic functions.

Registering
Registration is usually completed when Switchvox is first installed. If this is the case, 
this page displays the first few characters of your Registration Code. You need these 
numbers if you call Switchvox Tech Support. If you have not yet registered Switch-
vox, use the Switchvox Admin Web Suite to do so.

Updating
To ensure you have the most current version of Switchvox, use the Update tool before 
doing anything else. This tool will tell you if you need to update to a new version. If 
you do need to update, follow the instructions described in the following sections.

Backup your current 
system

• Create and download a backup of your current system (see Making a Backup on 
Demand, page 12).

• Locate your Switchvox installation DVD.

• Ensure no one is currently using Switchvox.

• Allow ample time to complete the update.

Locate Update file • Go to Server > Maintenance > Updates.

• Locate the update in the list. 
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Updating
• After you locate the update file, you may click either the Download or Download 
and Apply icon.

Important Notes 
about updating

• If the Updates page says no updates are available for your system, then you 
already have the newest version of the software and updating is not necessary.

• If there are one or more updates listed, you can review the update’s release note by 
clicking its more info... link.

• If you see a message indicating the system is offline, put the system online before 
trying to download an update again.

• Do not refresh your web browser during either download action. To check on the 
status of the update, go to: https://YourSwitchvox/admin?cmd=check_update

• After you apply an update, Switchvox removes the files for that update and any 
previous updates you may have downloaded.

Download Update file • Click the Download icon for the update you want to use.

A progress indicator tells you how long the download will take. 

NOTE: This action makes the necessary files available for your Switchvox sys-
tem, but it does not apply them.

• After the download is complete, you can apply the update whenever it is conve-
nient.

Download and Apply 
Update file

• Click Download and Apply for the update you wish to use to download and apply 
the update immediately.

Verify System and 
Phone Functionality 

After applying the upload, do the following to verify that the system is functioning 
properly:

• Go to Server > Diagnostics > Connection Status to make sure phones are regis-
tered and there are no new alarms.

• Go to Server > Networking > IP Configuration to make sure those settings are 
correct.

• Make a call from a Switchvox extension to another extension, and to an external 
phone number.

• If possible, make a call into Switchvox (e.g., from a mobile phone) to ensure your 
main IVR is responding normally.

• If appropriate, check sending and receiving of faxes.

Create a New Backup After completing the update, create a new backup of the system.
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Backups
Backups
Switchvox lets you create and download a backup file that can contain much of the 
data and audio files for Switchvox. This file may be restored back into Switchvox at 
any time to return Switchvox to the same state it was in when the backup was created. 
Switchvox backups can be created on demand, or scheduled to happen on a regular 
basis.Switchvox lets you set up an automated backup schedule with file transfer to the 
FTP server of your choice.

Any time you are going to make changes to Switchvox, such as move the hardware or 
restart the system, it is important to make a backup of the system and have it available 
to restore the system if need be.

IMPORTANT: The best practice for backups is to schedule a daily 
automatic backup that stores the backup file on an FTP server. For 
details, see Creating Automatic Backups, page 12.

Making a Backup on 
Demand

Select Server > Maintenance > Backups from the Web Admin Suite.

• Click Create Backup.This displays the Create Backups page.

• On the Create Backups page, click the check boxes next to any of the optional 
components that you want to include. The only thing that you cannot include in a 
backup is Call Recordings; those are backed up separately. For details, see Tools > 
PBX Features > Call Recording Settings in the online help in the Switchvox 
Admin Tools Web Suite.

• Click Save Backup. This creates the backup and redisplays the main page.

WARNING: The backup process may take several minutes depending 
on the amount of content. Do not click any links or buttons during the 
backup processing.

After the backup is created, the Backups page is displayed with the new backup in the 
Backups table. Click Download to save the backup (which may include multiple 
files) on your hard drive. Be sure to put backup files in a location from which they can 
be easily accessed to restore your system.

Creating Automatic 
Backups

Select Server > Maintenance > Backups from the Web Admin Suite.

• Click Set Up Automatic Backups. This displays the Automatic Backups page.

• Set the day of the week and the time to run the backup process. It is a good idea to 
set this outside of your business hours.

• Set the number of backup files to keep. When this number is exceeded, the oldest 
backup is deleted from the FTP host.

• Set the hostname of your FTP server, the username and password you use to 
access the server, and the path to the directory where you want to store the backup 
files.

• Click Test FTP Settings to be sure your backup files can be transferred.
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Backups
• For each directory you want to include in the backup, made sure that directory is 
set to Yes.

• Click Save Settings. This saves the backup information and displays the main 
Backups page.

To disable automatic backups, clear all FTP information, then click Save Settings. 
Those changes are saved, and the main Backups page is displayed.

Deleting a Backup 
File

To delete a backup file from the list, click its Delete button. 

• Click Yes, Delete Backup. 

• That backup file is permanently deleted from the system and removed from the 
list. 

• The Backup page is displayed with a message indicating that the file has been 
deleted.
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3 Phones and Calling

Managing Phone Extensions

Using Digium Phones

Contacts

Call Routing
This chapter describes the basics of managing extensions, using Digium phones, the 
Contacts application, and call routing. 

Managing Phone Extensions
Extensions are the numbers Switchvox uses to send a caller to various destinations. 
There are several different types of extensions, including extensions for phones, 
IVRs, call queues, etc.

The Manage Extensions page (Setup > Extensions > Manage) shows the extensions 
currently in Switchvox and lets you create, modify, and delete extensions.

Switchvox comes with some predefined extensions. We suggest you leave those 
extensions in place until you are sure you do not want to use them.

Switchvox offers the following tools to manage your phone extensions:

• “Extension Groups” ( page 15)

• “Extension Templates” ( page 15)

• “Bulk Modify Extensions” ( page 15)

• “Extension Permissions” ( page 15)

The combination of Extension Groups and Templates lets you set up everything the 
way you want and allows you to easily add new employees. This feature also lets you 
group extensions together for use in other Switchvox tools. An Extension Group can 
contain any kind of extension, even other groups.

You may want to match your Switchvox Extension Groups with your company's 
functional groups. That's because it is likely people who have the same job functions 
are going to need the same kinds of tools and permissions.
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Managing Phone Extensions
Extension Groups Extension Groups allows you to define a group of characteristics that can be applied 
to an extension. For example, if you have defined a group of characteristics for new 
hires, when you have a new hire, all you need to do is put his or her extension into that 
group to ensure the extension has all the right features and functionality needed to do 
the job.

Other Extension Groups can be used for the following:

• Call Queue members

• Permissions Holders (in Extension Permissions)

• Outgoing Caller ID rules for allowing extensions that can be dialed from an IVR

• Setting extensions to be automatically recorded

Extension Templates Extension Templates contain almost all of the same settings as the Phone-type Exten-
sions, except for the personal information of the extension owner. Templates even 
contain the membership in Extension Groups, so using well-defined templates can 
make it simple to set up new employees.

If most of your phone-type extensions will be set up the same way, you can modify 
the default template to suit your needs. If not, you can create multiple templates for 
different types of employees.

Each time you create a SIP, Virtual, or Analog extension, you choose an Extension 
Template. Then when the Create Extension page opens, all of the settings match that 
template, and you don't have to do all of that work again.

Extension settings can always be changed. If you have a special case, you can create 
the extension with a template, then modify the extension to change one or two set-
tings.

For example, you might want all international-sales staff to have a similar setup: a SIP 
phone with outgoing international calling enabled, Switchvox Mobile enabled, and 
membership in the Extension Group Intl-Sales (which happens to have membership in 
the Intl-Sales Call Queue). You can use a template to create all of the international-
staff extensions, which saves you time and ensures consistency.

Bulk Modify 
Extensions 

Bulk Modify allows you to modify settings for a set of extensions all at the same time:

• Go to Setup > Extensions > Manage and click Bulk-Modify Extensions.

•Add the extensions you want to modify to the Extensions collection box.

•Select the Phone Extension Field you want to modify, then select a setting 
within that type.

•Specify the value.

•Click Next.

•Review the Modifications you entered. You can edit them or delete them.

•If acceptable, click Save Modifications.

Extension 
Permissions

The Extension Permission feature allows one extension to have access to another 
extension to do the following:
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Using Digium Phones
• View calls. This includes seeing the incoming caller ID for the target's call.

• Record calls. These recordings are kept in the recorder's mailbox.

• Monitor calls, including whisper and barge.

• Pick up ringing calls.

• Intercom to the target phones.

Using Digium Phones

The following sections describe the tools to help you manage your Digium Phones 
and their extensions:

Digium Phone 
Assignments

Digium Phone Assignments define how SIP extensions are associated with a Digium 
Phone MAC address. To view a list of extensions and phones, both assigned and unas-
signed, go to

Setup > Digium Phones

You can create assignments one at a time, or use the Quick-Create option to create 
multiple assignments at the same time.

Anywhere in the Digium Phone Assignments area with a Phone MAC Address field, 
you can use a barcode scanner to scan the barcode on the phone box and retrieve the 
MAC Address.

To assign additional extensions to a MAC address (Lines 2-6), first assign Line 1 to a 
Switchvox extension. Then, modify the assignment and add the additional lines. Lines 
2-6 can be Switchvox extensions, or external extensions.

Phone Assignment 
Options

Phone Assignment Options control what password must be used to allow someone 
standing at the phone to choose that phone's extension. Or, you can specify that for a 
specific period of time, no password is required (called an Open Enrollment Period). 
Go to

 Setup > Digium Phones > Assignment Options

IMPORTANT: If an assignment is server-based, someone at the phone 
is never allowed to choose the phone's extension. When the phone is 
turned on or restarts, it automatically uses its server-based extension 
assignment. Server-based assignment includes the Digium Phone 
Assignment area, Bulk Import, or Extend API. If this is a problem, 
delete the Assignment, and reassign the phone.

Phone Settings The settings on the Digium Phones tab of a phone extension, along with those on the 
Common Settings tab, let you control almost everything about the Digium Phone 
assigned to an extension. The settings here are also available in Extension Templates 
and Bulk Modify.

All of the settings on a Digium Phone, except volume, can be controlled by one of the 
tools in the Switchvox web suite. Depending on the permissions you offer each exten-
sion, some of the phone settings can also be controlled by the extension owner.
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Using Digium Phones
Phone Settings for 
Remote Use

A remote phone is any phone not connected to the Switchvox local area network 
(LAN). If you have employees using Digium phones not connected to the LAN, you 
need to make sure Switchvox can communicate with these phones. The following 
describes how to set up s these phones:

• Make sure Access Control contains a network location for the employee (this is 
the phone’s external IP address), with the following services set to Yes:

•Digium Config Server

•User API

•SIP

• Make sure your router is forwarding the appropriate ports back to Switchvox. See 
“Port Forwarding for Remote Access” ( page 8).

• Make sure the Phone Assignment has the correct extension and MAC address.

• Make sure Phone Networks contains the network information for the phone. This 
is most likely covered by the All Networks settings, and should not require 
changes.

• Plug the phone into your local network.

• Wait until the phone obtains its configuration from Switchvox.

• Make a test call to be sure the phone is configured correctly.

• Unplug the phone and send it to your employee.

• After the employee plugs the phone in and the idle screen displays the date and 
time, the phone is ready to make calls.

Phone Tools Restart. This is found under Settings > Restart, or under Menu > Advanced > 
Restart.

Restart uses the configuration information already available on the phone. The phone 
asks you to confirm the restart.

Reconfigure. This is found under Menu > Advanced > Reconfigure.

Reconfigure begins the configuration process again, and reconfigures the phone. This 
process does not remove the current configuration until the new configuration is 
obtained.

Reset to Factory Defaults. This is found under Settings > Reset to Factory 
Defaults, or under Menu > Advanced > Reset to Factory Defaults.

Reset to Factory Defaults clears all configuration information in the phone and starts 
over. 

CAUTION: This tool removes all existing lines (SIP Accounts) and contacts as 
well as configuration information.

Select Network.  This is found under Settings > Select Network (option 6) or under 
Menu > Preferences > Select Network (option 4). This tools lets you select the spe-
cific Phone Network you want the phone to use to get on the network and find Switch-
vox.
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Contacts
Tech Support. This is found under Settings > Tech Support, or under Menu > 
Admin Settings > Tech Support.

The Tech Support tool allows Digium to access your phone to help diagnose a prob-
lem via a VPN connection. 

IMPORTANT: Do not use this tools unless it is at the request of a Digium 
Technical Support representative.

Network Utilities. This is found under Settings > Tech Support > Network Utili-
ties, or under Menu > Admin Settings > System Tools > Tech Support > Network 
Utilities.

These tools help you diagnose network issues:

• Ping
Tests the reachability of a host on the Internet.

• Traceroute
Displays the route (path) and measures transit delays of packets across the net-
work.

• NSlookup
Queries the domain name system to obtain the domain name or IP address map-
ping or for any other specific DNS record.

• List mDNS Services
Lists the devices broadcasting mDNS that the phone can see on the network .

Contacts
The Contacts page (Tools > Extension Features > Contacts) controls a set of con-
tacts that are put on each Digium Phone and that Switchvox uses in various directory 
areas. 

Users can also control the contacts on their Digium Phones with the Phonebook fea-
ture. This feature also controls the user's Rapid Dial Keys on the Digium Phone.

Digium Phones support up to 1,000 contacts, including admin contacts and personal 
phonebook entries. By default, the Internal Directory is available on all of your Dig-
ium phones, and it includes all of the Switchvox extensions. 

Internal Directory Go to Tools > Contacts: Internal Directory.

The Contacts page gives you control over the Internal Directory on Digium phones 
and in the Switchboard. The extensions in the Internal Directory are always included 
in the Contacts app.

NOTE: The Internal Directory is also available on Polycom phones 
configured with a Phone Feature Pack, under the Switchvox Directory 
application.
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Call Routing
External Contacts Go to Tools > Contacts: External Contacts.

The Contacts page lets you put External Contacts in every Digium Phone's Contacts 
app. External contacts can be useful for contacts on a peered Switchvox. The Internal 
Directory section has an option to download the directory as an XML file. If you 
download that file, you can upload it to the peered Switchvox's External Contacts. 
This way, all of your employees can have the Internal Directory of both Switchvoxes.

External Contacts for 
Digium Phones

To add external Contacts (Contacts that aren't extensions on this Switchvox) to all 
Digium phones, you can upload a CSV or XML file. To see an example of the XML 
used by Contacts, download the Internal Directory's XML file.

CSV headers:

first_name, last_name, organization, job_title, location, 
email_address, primary_number, primary_number_label, 
secondary_number, secondary_number_label, jabber_id, 
subscription_url

Example of the CSV record for one of your vendors:

Jane,Doe,Bunches of Flowers,Designer,San 
Diego,jane@bunchesofflowers.com,918585551212,Flower 
Stand,918585553333,Mobile,,,

Call Routing

With Switchvox you have total control over how to make calls via the Call Routing 
tools.

Channel Groups Channel Groups lets you manage your hardware device channels. You can enable 
multiple signaling methods, configure a callback extension, and also set advanced 
options for echo cancellation, noise reduction, and more.

If you have analog or digital lines you want to connect to Switchvox, then you'll need 
to purchase the appropriate Digium Telephony Card and set it up in Setup > Call 
Routing > Channel Groups in the Admin Tool Suite.

The Channel Groups tool displays all the channels available and lets you group chan-
nels by signaling type. You can also modify or delete existing channel groups.

To create a channel group, click Create Channel Group. This displays the Channel 
Group Configuration page.

1. Enter a name for the channel group.

2. Specify the device type, that is the type of line connected to Switchvox through 
this device. See the online help in the Switchvox Admin Tools Web Suite for 
options.

3. Select the channels to add to the group.
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Call Routing
4. For the channel, enter the Callback Extension, that is the extension to ring when a 
voice call comes in over this provider or channel and the Default Fax Extension 
for the channel, that is the extension to ring when a call comes in over this pro-
vider or channel and is identified as a fax.

5. Unless you are an advanced user, do not change any of the other settings.

6. Click Save Channel Group to create the group.

WARNING: Switchvox restarts after you create a new channel. Any 
current calls are dropped, and any agents logged into queues are logged 
out.

VoIP Providers VoIP providers can be either commercial VoIP phone services or other VoIP hardware 
such as a peered Switchvox. There are two types of providers: SIP or IAX. These are 
two common protocols used for placing phone calls over the internet. If you are 
unsure which protocol to use, ask your service provider.

For either provider type, the only information you need for them is the Provider Infor-
mation.There are multiple tabs available with advanced settings, but most likely you 
do not need to change those settings from the defaults.

After you have created a provider, you are prompted to go to the System Status page. 
This page displays your VoIP providers and their statuses. If Switchvox successfully 
contacts your provider, it is displayed as Registered. Now if you call your own num-
ber (the number your provider gave you), your call should ring the Callback Exten-
sion.

Outgoing Calls The Outgoing Calls tools let you handle all aspects of outgoing calls, including call 
rules, caller ID rules, and call diagnostics.

Outgoing Call Rules. An outgoing call rule is a dialing pattern and associated rout-
ing information. For example, the International outgoing call rule is triggered when a 
user dials “9011” followed by 7 to 13 digits. Such calls are sent to the selected route 
(such as a VoIP provider or a Channel Group).

You can create multiple call rules that match the same pattern. In this case, if there is a 
pattern match, the rule that is highest in the priority list gets called first. If that rule 
fails, and it is not marked as a final rule, the next rule is called, and so on.

Switchvox is preconfigured with a set of outgoing call rules that serve most situations. 
You can modify or delete those Rules, and create your own.

Outgoing Caller ID Rules. Outgoing Caller ID rules let you modify the outgoing 
caller ID name and number. Caller ID rules can apply to:

• A single extension.

• Any extension. (Use a Single Rule, and put the word any in the Select Extension 
field.)

• A range of extensions.

• An extension group.
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If you use a ranged Caller ID rule, you can derive an extension’s correct caller ID by 
adding and prepending numbers to the extension. For example, if you have an exten-
sion block from 100 to 200, and a DID block of 800-555-1200 - 800-555-1300, you 
would use the following ranged rule:

When an extension is in the range from 100 to 200 and is making an outgoing call 
through rule Any Outgoing Rule, change their caller id to a number derived by adding 
100 to their extension and prepending 8005551.

NOTE: Not all VoIP providers support this feature and some VoIP pro-
viders do not work properly with altered Caller IDs. Also, it is not possi-
ble to set Caller ID on regular analog phone lines.

Outgoing Call Diagnostics. Outgoing Call Diagnostics can be used to determine 
which Outgoing Call Rule is being used and why. If you set Enable Diagnostics to 
YES, diagnostic information is read over the phone to all callers from all extensions.

When using the Diagnostic mode, make sure the number you are dialing matches the 
pattern for the rule. If the pattern does not match, your outgoing call will not be con-
nected using that rule. If the number you have dialed does match the pattern for the 
rule, make sure the extension you are placing the call from has permission to call 
through that rule (see the online help in the Switchvox Admin Tool Web Suite for 
Outgoing Call Rules).

Incoming Calls The Incoming Calls tools let you manage incoming call rules and routes.

DID Routes. A DID Route maps numbers coming in on a particular Provider or 
Channel Group to a particular extension. By default, Switchvox creates a DID route 
(the callback extension) for each interface as they are created (i.e., each provider has a 
rule). You can add new rules that allow for specialized routing based on information 
sent by the provider or deduced from the channel group.

To create a new DID route, click Create Single DID Route or Create Ranged DID 
Route. A Single DID Route always routes calls to a single, specific extension. A 
Ranged DID Route derives the correct extension number from the DID.

You can put all of the DID Routes in order, to ensure that call reach the correct exten-
sion.

Caller ID Rules. You can create, modify, prioritize, and delete incoming call rules 
that apply to the extensions on Switchvox. Incoming call rules let you perform actions 
on calls based on who is calling you. These rules are system wide and happen before 
any of the extensions' call rules are triggered.
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4 Customer Service Basics

Using Time Frames

Call Queue Extensions

IVR 

Conference Calls 

Voicemail Administration
This chapter describes the basic customer service tools, including Time Frames, Call 
Queue Extensions, IVR, conference calls, and voicemail administration.

Using Time Frames
Switchvox can operate differently based on the date, day, and time. You can set up 
IVR Menus and Call Rules to check the Time Frames, and then act accordingly. 
There are several predefined time frames you can use: Business Hours, Outside Busi-
ness Hours, and Weekends Only. You can modify or delete these time frames, or cre-
ate new ones.

IMPORTANT: A time frame is considered valid when the current date 
and time match any one of a time frame’s conditions. Not all of the con-
ditions in the time frame have to match the current date and time.

Time frames consist of Time Frame Conditions. The time frame itself is considered 
valid when any of its conditions are met.

To modify a Time Frame with Conditions:

1. From Tools > PBX Features > Time Frames, click Create Time Frame Condi-
tions.

2. Enter a Date Range, Day of the Week Range, or a Time Range, or any combina-
tion.

Continue adding conditions until you have completed the Time Frame definition.
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Call Queue Extensions
A Call Queue Extension lets an incoming call ring a group of extensions so any one of 
those extensions can pick up the call. There are many things you can do with the Call 
Queue Extensions tool, but all you really need is Queue Setup and Queue Members.

Queue Setup The Queue Setup settings determine the basic information about the queue:

1. Go to Setup > Extensions > Manage.

2. Click Create Extension.

3. Select Call Queue.

Queue Extension. •Enter a unique number for this extension. For information about 
the extension-number length, see the online help in the Switchvox Admin Tools 
Web Suite, Extension Settings.

Queue Name. Enter the name of the queue (e.g., Sales or Customer Service).

Ringing Strategy. Select one of the following strategies:

• Ring All. Ring all queue members simultaneously until someone answers.

• Round Robin. Take turns ringing each queue member evenly as calls come into the 
queue.

• Least Recently Called. Ring the queue member for whom the most time has passed 
since taking his last call.

• Fewest Calls. Ring queue member who has taken the fewest calls in the queue.

• Random. Randomly ring queue members.

• In Order. Ring queue members in order, always starting with the first member in 
the list.

Queue Members Queue Members are extensions that can log into the queue and receive calls from the 
queue. Only phone extensions are valid queue members. Permanent members are per-
manently logged in so they can always receive calls to the queue. This collector box 
lets you find and collect extensions or groups that belong in this queue.

To put an extension or group into the collection:

• Type a name or extension number into the text field. As you type, Switchvox 
offers suggestions of matching extensions.

• Click the Find icon to display the extensions available in Switchvox. You can sort 
this view by the column headers. If you are working with phone-type extensions, 
you can expand the window to show an extension's profile.

• To mark an extension or group as Permanent or Login, select them and click the 
appropriate icon.

The order of members in the list is important. For example, if Round Robin is the ring 
strategy, it calls the member in the first position, then the second, and so on. If In 
Order is the ring strategy, it always tries to call the members in order, starting with the 
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first member. If you have an extension group in the queue, the group's order is used. 
Any non-phone extensions in a group are ignored.

To put items in the right order, select the items you want to move, then click the Up, 
Top, Down, or Bottom button.

To select multiple items in the collection:

• Control-click to select two or more items that aren't together in order.

• Click an item, then Shift-click another item to select both items and all items 
between them.

• To delete an item from the collection, select it and click the Delete icon.

IVR Basics
This section gives an example of how to create an IVR that covers the basic functions 
most companies need. This example IVR has the following actions:

• Answer the main line with a recorded greeting.

• If it is after business hours, tell callers the normal business hours.

• Tell callers that if they know their party’s extension, they can dial it at any time. 
(This is considered the beginning of the main IVR, so if we send callers back to 
the beginning of the menu we don’t force them to listen to our greeting each time.)

• Offer callers an option to use the company directory.

• Offer callers an option to hear a recorded service announcement.

• If it is after business hours, offer callers the option to leave a message.

• If it is during business hours, offer callers the option to speak to a Customer Ser-
vice representative.

NOTE: If possible, use option numbers that do not start with the same 
digit that your extensions start with.

For more information about creating advanced IVRs, see the online help in the online 
help in the Switchvox Admin Tools Web Suite for descriptions of each IVR action 
you can use and the website for use cases and how to use the actions to accomplish 
your goals.

Sounds The Sound Manager lets you create, upload, modify, and delete all of the sounds in 
Switchvox other than Music On Hold. It also lets you organize your sounds in folders, 
and manage the same sounds that are in different languages. Sounds can be uploaded 
from your computer, or recorded over any phone connected to Switchvox.

Use the main page of the Sound Manager to see and manage your sounds:

1. Go to Tools > Media > Sound Manager

2. Click Create and select from the dropdown: Sound, Sound Pack, Folder, or 
Language

3. Click Go
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4. When the settings are correct, click Save Sound. (If you are uploading a file, the 
transfer begins). The system redisplays the Sound Manager main page with a mes-
sage that a new sound has been added, and the new sound is included in the list of 
sounds.

You need to create a new Sound Manager Folder for each IVR and put your custom 
sounds in that folder. The following are some examples:

Business Hours “Our business hours are Monday through Friday, from 
9:00am to 5:00pm.”

Dial Extension “If you know your party’s extension, you can dial it at 
any time.”

For Customer Service “For Customer Service press 3.”

Greeting “Hello, thank you for calling! We’re happy to help you.”

Main Menu “Main Menu.”

Service Announcement “All services are functioning normally.”

To hear Main Menu “Press the star key to hear this menu again.”

To hear Service Announcement “To hear our current service announce-
ment press 2.”

Use the Directory “To use our company directory press 1.”

IVR Menus Creating IVR Menus is a multi-step process. First create the IVR Main menu, fol-
lowed by any other IVRs, then go back and finish the entire IVR.

1. Go to Tools > IVR Editor

2. Click Create IVR Menu

3. Name it Main IVR

4. Create an action to play the sound 'Dial Extension' and make it interruptible.

5. Set up each of the component IVR menus as follows:

Component Actions

Start at Main Play Sound ‘Main Menu’ (Interruptible)

Go To IVR Menu / Action: Main IVR at entry point Play 
Sound (Dial Extension)

Play Business Hours Play Sound ‘Business Hours’ (Not Interruptible)

Dial Directory

Dial Extension 411
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3. Finish setting up Main IVR with the following actions:

Play Sound ‘Greeting’ (Not Interruptible)

Time Based Clause: within the time range Outside Business Hours, go 
to Play Business Hours at entry point IVR Menu Beginning

Play Sound ‘Dial Extension’ (Interruptible)

Play Sound ‘Use the Directory’ (Interruptible)

Play Sound ‘To hear Service Announcement’ (Interruptible)

Play Sound ‘For Customer Service’ (Interruptible)

Play Sound ‘To hear Main Menu’ (Interruptible)

Option 1: Dial Directory at IVR Menu Beginning

Option 2: Service Announcement at IVR Menu Beginning

Option 3: Customer Service at IVR Menu Beginning

Option *: Start at Main at IVR Menu Beginning

Option Setting: Enable extension dialing: Extension Group that can be 
dialed

Extensions Set up (or verify) the following extensions in Manage Extensions:

Main IVR (800)—This should be an IVR extension.

Customer Service (611)—This should be a Call Queue extension.

Play Service Announcement Play Sound ‘Service Announcement’ (Interruptible)

Go To IVR Menu / Action: Start at Main at entry point 
IVR Menu Beginning

Dial CS Dial Extension 611

Dial CS Voicemail Send to Voicemail 610

Customer Service Time Based Clause: within the time range Outside Busi-
ness Hours, go to Dial CS Voicemail at entry point IVR 
Menu Beginning

Go To IVR Menu / Action: Dial CS at entry point IVR 
Menu Beginning
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CustomerService Voicemail (610)—This should be a Virtual extension.

Directory (411)—This should be a Directory extension.

Employee phone extensions—These should be SIP extensions for your 
employees.

NOTE: The Customer Service Voicemail extension can be set to for-
ward all of its voicemail to your customer service representatives using 
the Extension Suite (/main) Voicemail Options and the Forwarding tab.

Testing Test your IVR. Call the extension yourself, listen to the sounds that are played, and try 
to dial an extension. Call several times, choosing each of the different options. You 
can test Option 3 and the Time Based Clause by changing your Time Frame Outside 
Business Hours (for details, see Using Time Frames, page 22). Or, change the Time 
Based Clause in Main IVR to During Business Hours, check to make sure you get the 
correct behavior for outside of business hours, then change the Time Based Clause 
back to Outside Business Hours.

A Working IVR To set up Switchvox so the Main IVR answers all of your calls, set your Callback 
Extension to 800 (the extension given the Main IVR). That setting is available on the 
VoIP provider page or in Channel Groups, depending on how your main phone num-
ber is handled.

Conference Calls

Phone users have three ways to make conference calls from their IP phones.

3-Way Conference 
Call from the Phone

The phone-user does the following:

• Presses the Conference key or softkey on the Digium phone. This places the main 
call on hold.

• Dials a third party's number.

• Presses Conference again to connect all 3 parties.

Simple Conference 
Room

The Switchvox Administrator can set up a simple conference extension, then any 
Switchvox user can call that extension to join the conference.

Meet Me Conference 
Center

The Switchvox Administrator can set up a Meet Me Conference extension. Then, 
each phone user has his or her own conference room number, so coworkers and cus-
tomers can join him/her in that conference.
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To manage a Conference Room, go to Features > Conference Room in the Web 
Users Suite.

Voicemail Administration
There is a set of options for your voicemail system in the Admin Tools Suite. 

Go to Tools > Voicemail

Voicemail Routing During a user’s voicemail greeting, callers may push the “*” key to log into the cur-
rent voicemail box. 

• Check the box if you want this to be true. 

• When the caller presses “*,” he or she is prompted for a password.

During a user’s voicemail greeting, callers may push the “0” key to exit and be for-
warded to extension []. 

• Enter an extension if you want this to be true. 

• Click the people icon to select from a list of extensions. 

• When the caller pushes “0,” he or she has the option to accept and save his/her 
recording before being transferred to the extension.

If a user’s voicemail box is full, callers will be forwarded to extension []. 

• Enter an extension if you want this to be true. 

• Click the people icon to select from a list of extensions.

Custom Voicemail 
Message Length

You can specify the number of seconds it takes for Switchvox to “give up” on a caller 
if they reach your voicemail but don’t leave a message. For example, if you specify 10 
seconds, and someone reaches your voicemail but they don’t start talking, Switchvox 
hangs up and does not save those 10 seconds of silence. Setting a number of seconds 
here should help reduce clutter in Mailboxes and on disk.

You can also set a number of seconds to let the caller speak, and after a call exceeds 
the time, it is disconnected. This is useful if you are concerned about storage capacity.
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